2012. 1. 30. 15:46 Log/Solaris
Solaris Basic CMD(s)
운영체제 기본적인 정보 확인 명령어
uname CMD
# uname -a
# cat /etc/release
date CMD
# rdate time.bora.net
# date +%m%d
cal CMD
디렉토리 이동 관련 명령어
pwd CMD
PS1 변수
cd CMD
PATH
- 절대경로(Absolute PATH) # cd /dir1
- 상대경로(Relatvie PATH) # cd dir1
파일의 종류
일반 파일
디렉토리 파일
링크 파일
하드링크(Hard Link) # ln file1 file2
심볼릭링크(Symbolic Link)# ln -s file1 file2
디바이스 파일
블럭디바이스(Block Device)
캐릭터디바이스(Character Device)
man & passwd CMD
man CMD
# man ls
# man -k calendar
# man -l passwd
# man -s 1B ls
passwd CMD
# passwd [USER]
--------------------------------------------------------
디렉토리 관리 명령어
ls CMD
# ls -l dir1
# ls -ld dir1
OPTIONS: -a, -l, -d, -t, -r, -F, -R, -h, -i
# ls -altr
mkdir CMD
# mkdir -p dir1/dir2/dir3
rmdir CMD
# rm -r dir1
파일 관리 명령어
touch CMD
cp CMD
# cp file1 file2
# cp file1 dir1
# cp -r dir1 dir2
OPTIONS: -i, -r, -p
mv CMD
# mv file1 file2
# mv file1 dir1
# mv dir1 dir2
OPTIONS: -i
rm CMD
# rm -rf dir1
# \rm -r dir1
파일 내용 확인 명령어
cat CMD
# cat -n file1
# cat file1 file2 > file3
more CMD
# CMD | more
# ps -ef | more
# pkginfo | more
# patchadd -p | more
head CMD
# alias pps='ps -ef | head -1 ; ps -ef | grep $1'
tail CMD
# tail -f /var/adm/sulog
# tail -f /var/adm/messages
# tail -f /var/adm/messages | grep DHCP
기타 관리용 명령어
wc CMD
Data Gathering
su CMD
# su user01
# su - user01
--------------------------------------------------------
id CMD
UID/EUID, GID/EGID
groups CMD
last CMD
who CMD
w CMD
while [ 1 ]
do
CMD
sleep 2
done
사용자와 통신할 때 사용하는 명령어
mailx CMD
# mailx -s "OK: solarisXXX" root@paran.com < report.txt
talk CMD
wall CMD
# wall -a /etc/hosts
파일 속성 정보 변경 명령어
chown CMD
# chown -R user01 dir1
chgrp CMD
chmod CMD
퍼미션 변경 방법
- Symbolic Mode(EX: chmod u+x file1)
- Octal Mode (EX: chmod 755 file1)
파일 & 디렉토리 퍼미션 의미
umask CMD
(관리자) /etc/profile
(사용자) $HOME/.profile
특수 퍼미션
SetUID/SetGID/Sticky Bits 의미
SetUID/SetGID/Sticky Bits 설정
SetUID/SetGID/Sticky Bits 관리
자주 사용되지 않지만 유용한 명령어
diff/cmp CMD
# diff file1 file2
# dircmp dir1 dir2
--------------------------------------------------------
sort CMD
# df -k -F ufs
# du -sk /etc
# cd /etc ; du -sk * | sort -nr | more
# sort -u file1
# sort file1 | uniq -d
# sort file1 | uniq -u
file CMD
# cd /etc ; file *
검색 관련 명령어
grep CMD
# grep OPTIONS PATTERN file1
OPTIONS: -c, -n, -l, -v, -i, -w
PATTERN: * . ^root root$ [abc] [a-c] [^a]
[참고] egrep, fgrep
find CMD
# find / -name core -type f
# find / -user user01 -group class1
# find / -mtime [-7|7|+7]
# find / -perm [-755|755]
# find / -size [-300c|300c|+300c]
# find / -name core -type f -exec rm {} \;
압축 & 아카이빙
압축(Compress)
compress/uncompress CMD
gzip/gunzip CMD
아카이빙(Archiving)
tar CMD
(/test1 -> /test2)
# cd /test1
# tar cvf - . | (cd /test2 | tar xvfp -)
------------------------------------------------------------------------
cpio CMD
압축 + 아카이빙(Compress & Archving)
zip CMD
jar CMD
Visual Editor
(vi) $HOME/.exrc(set nu)
(vim)$HOME/.vimrc(syn on)
Korn Shell 특징
Redirection
------------------
fd
------------------
0 stdin
1 stdout
2 stderr
------------------
Redirection stdin (EX: mailx -s WARN root < report.txt)
Redirection stdout(EX: ls -l > file.txt)
Redirection stderr(EX: CMD > file.log 2>&1)
Pipe
CMD | more
CMD | grep inetd
CMD > file.log
CMD | tee file.log
ksh function
# set -o
# set -o vi
# set +o vi
# set -o noclobber
# set -o vi
# set -o ignoreeof
Variable
변수의 종류
- 지역 변수
- 환경 변수
- 특수 변수
변수 선언 방법
export 의미?
시스템 환경변수(set/env)
EDITOR/VISUAL
PS1/PS2
PATH/MANPATH/LD_LIBRARY_PATH
HOME/PWD/LOGNAME
DISPLAY
------------------------------------------------------------
Metacharacter
'' "" `` \ ;
History
(ksh) $HOME/.sh_history
(bash)$HOME/.bash_history
r, r vi
Alias
# alias cp='cp -i'
# alias
# unalias cp
환경파일
/etc/profile
$HOME/.profile
$HOME/.kshrc
쉘별 환경 파일
sh ) /etc/profile, ~/.profile
ksh ) /etc/profile, ~/.profile, ~/.kshrc
bash) /etc/profile, ~/.bash_profile, ~/.bashrc
csh ) /etc/.login, ~/.cshrc, ~/.login
/etc/skel
(주) /etc/profile
(부) /etc/skel
Process Admin
Process Information
/proc/PID(pCMD: ps, pfiles, pstack, pmap, ...)
PID, PPID, UID/EUID, TTY
Process Admin I
프로세스 실행
fg) # ls
bg) # ls &
프로세스 확인
# ps -ef | grep inetd
OPTIONS: -l, -f
-e, -a, -U, -t
------------------------------------------------------------
프로세스 종료
# kill -[1|2|9|15] PID PID
[참고] pgrep, pkill
Process Admin II
잡 실행
fg) # ls
bg) # ls &
잡 확인
# jobs
잡 종료
# kill %1
<CTRL + Z>, stop %1
Process Monitoring
# ps -ef | grep inetd
# prstat
원격접속 & 파일전송
System V
telnet CMD
원격접속 에러메세지
ftp CMD
/etc/ftpd/ftpusers
/etc/shells
[참고] auto_ftp.sh, telnet.sh
------------------------------------------------------------
BSD
rlogin CMD
rsh CMD
rcp CMD
Secure
ssh CMD
sftp CMD
scp CMD
ACL(Access Control List)
getfacl CMD
setfacl CMD
------------------------------------------------------------
'Log > Solaris' 카테고리의 다른 글
SOLARIS10 Admin I Guide (0) | 2012.02.09 |
---|---|
SOLARIS10 Essential Guide (0) | 2012.02.09 |